昨天我发了一个利用易语言制作mc简单的注入挂的文章,我发现发易语言类文章很简单,于是今天我又来了,昨天竟然有人说我这种代码太垃圾,我也懒得追究了,下面我们来看一下这个工具的外观

图1

这个界面是不是特别的简洁,废话不多说,直接上代码

    .版本 2

    .程序集 窗口程序集1
    .程序集变量 SECURITY_ATTRIBUTES, SECURITY_ATTRIBUTES
    .程序集变量 STARTUPINFO, STARTUPINFO
    .程序集变量 PROCESS_INFORMATION, PROCESS_INFORMATION
    .程序集变量 hWrite, 整数型
    .程序集变量 hRead, 整数型
    .程序集变量 txt, 字节集
    .程序集变量 len, 整数型
    .程序集变量 tmp, 整数型

    .子程序 _按钮1_被单击

    SECURITY_ATTRIBUTES.nLength = 12
    SECURITY_ATTRIBUTES.lpSecurityDescriptor = 0
    SECURITY_ATTRIBUTES.bInheritHandle = 1
    tmp = CreatePipe (hRead, hWrite, SECURITY_ATTRIBUTES, 0)

    STARTUPINFO.cb = 68
    GetStartupInfo (STARTUPINFO)
    STARTUPINFO.dwFlags = 位或 (#STARTF_USESHOWWINDOW, #STARTF_USESTDHANDLES)
    STARTUPINFO.wShowWindow = #SW_HIDE
    STARTUPINFO.hStdOutput = hWrite
    STARTUPINFO.hStdError = hWrite
    .判断开始 (选择框1.选中 = 真)
    CreateProcess (0, “ping ” + 编辑框2.内容, 0, 0, 真, 0, 0, 0, STARTUPINFO, PROCESS_INFORMATION)
    .默认
    CreateProcess (0, 编辑框2.内容, 0, 0, 真, 0, 0, 0, STARTUPINFO, PROCESS_INFORMATION)
    .判断结束

    tmp = CloseHandle (hWrite)
    .循环判断首 ()
    txt = 取空白字节集 (4096)
    tmp = ReadFile (hRead, txt, 4095, len, 0)
    编辑框1.加入文本 (取字节集数据 (txt, #文本型))
    处理事件 ()
    .循环判断尾 (tmp ≠ 0)

    .版本 2

    .程序集 窗口程序集1
    .程序集变量 SECURITY_ATTRIBUTES, SECURITY_ATTRIBUTES
    .程序集变量 STARTUPINFO, STARTUPINFO
    .程序集变量 PROCESS_INFORMATION, PROCESS_INFORMATION
    .程序集变量 hWrite, 整数型
    .程序集变量 hRead, 整数型
    .程序集变量 txt, 字节集
    .程序集变量 len, 整数型
    .程序集变量 tmp, 整数型

    .子程序 _按钮1_被单击

    SECURITY_ATTRIBUTES.nLength = 12
    SECURITY_ATTRIBUTES.lpSecurityDescriptor = 0
    SECURITY_ATTRIBUTES.bInheritHandle = 1
    tmp = CreatePipe (hRead, hWrite, SECURITY_ATTRIBUTES, 0)

    STARTUPINFO.cb = 68
    GetStartupInfo (STARTUPINFO)
    STARTUPINFO.dwFlags = 位或 (#STARTF_USESHOWWINDOW, #STARTF_USESTDHANDLES)
    STARTUPINFO.wShowWindow = #SW_HIDE
    STARTUPINFO.hStdOutput = hWrite
    STARTUPINFO.hStdError = hWrite
    .判断开始 (选择框1.选中 = 真)
    CreateProcess (0, “ping ” + 编辑框2.内容, 0, 0, 真, 0, 0, 0, STARTUPINFO, PROCESS_INFORMATION)
    .默认
    CreateProcess (0, 编辑框2.内容, 0, 0, 真, 0, 0, 0, STARTUPINFO, PROCESS_INFORMATION)
    .判断结束

    tmp = CloseHandle (hWrite)
    .循环判断首 ()
    txt = 取空白字节集 (4096)
    tmp = ReadFile (hRead, txt, 4095, len, 0)
    编辑框1.加入文本 (取字节集数据 (txt, #文本型))
    处理事件 ()
    .循环判断尾 (tmp ≠ 0)
    .版本 2

    .程序集 窗口程序集1
    .程序集变量 SECURITY_ATTRIBUTES, SECURITY_ATTRIBUTES
    .程序集变量 STARTUPINFO, STARTUPINFO
    .程序集变量 PROCESS_INFORMATION, PROCESS_INFORMATION
    .程序集变量 hWrite, 整数型
    .程序集变量 hRead, 整数型
    .程序集变量 txt, 字节集
    .程序集变量 len, 整数型
    .程序集变量 tmp, 整数型

    .子程序 _按钮1_被单击

    SECURITY_ATTRIBUTES.nLength = 12
    SECURITY_ATTRIBUTES.lpSecurityDescriptor = 0
    SECURITY_ATTRIBUTES.bInheritHandle = 1
    tmp = CreatePipe (hRead, hWrite, SECURITY_ATTRIBUTES, 0)

    STARTUPINFO.cb = 68
    GetStartupInfo (STARTUPINFO)
    STARTUPINFO.dwFlags = 位或 (#STARTF_USESHOWWINDOW, #STARTF_USESTDHANDLES)
    STARTUPINFO.wShowWindow = #SW_HIDE
    STARTUPINFO.hStdOutput = hWrite
    STARTUPINFO.hStdError = hWrite
    .判断开始 (选择框1.选中 = 真)
    CreateProcess (0, “ping ” + 编辑框2.内容, 0, 0, 真, 0, 0, 0, STARTUPINFO, PROCESS_INFORMATION)
    .默认
    CreateProcess (0, 编辑框2.内容, 0, 0, 真, 0, 0, 0, STARTUPINFO, PROCESS_INFORMATION)
    .判断结束

    tmp = CloseHandle (hWrite)
    .循环判断首 ()
    txt = 取空白字节集 (4096)
    tmp = ReadFile (hRead, txt, 4095, len, 0)
    编辑框1.加入文本 (取字节集数据 (txt, #文本型))
    处理事件 ()
    .循环判断尾 (tmp ≠ 0)

想要让程序运行,光着一个代码可不行,还需要变量和自定义数据和dll
下面我一个个放
自定义数据类型表

    .版本 2

    .数据类型 STARTUPINFO
    .成员 cb, 整数型
    .成员 lpReserved, 文本型
    .成员 lpDesktop, 文本型
    .成员 lpTitle, 文本型
    .成员 dwX, 整数型
    .成员 dwY, 整数型
    .成员 dwXSize, 整数型
    .成员 dwYSize, 整数型
    .成员 dwXCountChars, 整数型
    .成员 dwYCountChars, 整数型
    .成员 dwFillAttribute, 整数型
    .成员 dwFlags, 整数型
    .成员 wShowWindow, 短整数型
    .成员 cbReserved2, 短整数型
    .成员 lpReserved2, 整数型
    .成员 hStdInput, 整数型
    .成员 hStdOutput, 整数型
    .成员 hStdError, 整数型

    .数据类型 SECURITY_ATTRIBUTES
    .成员 nLength, 整数型
    .成员 lpSecurityDescriptor, 整数型
    .成员 bInheritHandle, 整数型

    .数据类型 PROCESS_INFORMATION
    .成员 hProcess, 整数型
    .成员 hThread, 整数型
    .成员 dwProcessId, 整数型
    .成员 dwThreadId, 整数型

    .版本 2

    .数据类型 STARTUPINFO
    .成员 cb, 整数型
    .成员 lpReserved, 文本型
    .成员 lpDesktop, 文本型
    .成员 lpTitle, 文本型
    .成员 dwX, 整数型
    .成员 dwY, 整数型
    .成员 dwXSize, 整数型
    .成员 dwYSize, 整数型
    .成员 dwXCountChars, 整数型
    .成员 dwYCountChars, 整数型
    .成员 dwFillAttribute, 整数型
    .成员 dwFlags, 整数型
    .成员 wShowWindow, 短整数型
    .成员 cbReserved2, 短整数型
    .成员 lpReserved2, 整数型
    .成员 hStdInput, 整数型
    .成员 hStdOutput, 整数型
    .成员 hStdError, 整数型

    .数据类型 SECURITY_ATTRIBUTES
    .成员 nLength, 整数型
    .成员 lpSecurityDescriptor, 整数型
    .成员 bInheritHandle, 整数型

    .数据类型 PROCESS_INFORMATION
    .成员 hProcess, 整数型
    .成员 hThread, 整数型
    .成员 dwProcessId, 整数型
    .成员 dwThreadId, 整数型
    .版本 2

    .数据类型 STARTUPINFO
    .成员 cb, 整数型
    .成员 lpReserved, 文本型
    .成员 lpDesktop, 文本型
    .成员 lpTitle, 文本型
    .成员 dwX, 整数型
    .成员 dwY, 整数型
    .成员 dwXSize, 整数型
    .成员 dwYSize, 整数型
    .成员 dwXCountChars, 整数型
    .成员 dwYCountChars, 整数型
    .成员 dwFillAttribute, 整数型
    .成员 dwFlags, 整数型
    .成员 wShowWindow, 短整数型
    .成员 cbReserved2, 短整数型
    .成员 lpReserved2, 整数型
    .成员 hStdInput, 整数型
    .成员 hStdOutput, 整数型
    .成员 hStdError, 整数型

    .数据类型 SECURITY_ATTRIBUTES
    .成员 nLength, 整数型
    .成员 lpSecurityDescriptor, 整数型
    .成员 bInheritHandle, 整数型

    .数据类型 PROCESS_INFORMATION
    .成员 hProcess, 整数型
    .成员 hThread, 整数型
    .成员 dwProcessId, 整数型
    .成员 dwThreadId, 整数型

    常量数据表

    .版本 2

    .常量 SW_HIDE,
    .版本 2

    .常量 SW_HIDE, "0"
    .常量 STARTF_USESHOWWINDOW, "1"
    .常量 STARTF_USESTDHANDLES, "256"
    .版本 2

    .常量 SW_HIDE,

    dll命令定义表

    .版本 2

    .DLL命令 CreateProcess, 整数型, ,
    .版本 2

    .DLL命令 CreateProcess, 整数型, , "CreateProcessA"
    .参数 lpApplicationName, 整数型
    .参数 lpCommandLine, 文本型
    .参数 lpProcessAttributes, 整数型
    .参数 lpThreadAttributes, 整数型
    .参数 bInheritHandles, 逻辑型
    .参数 dwCreationFlags, 整数型
    .参数 lpEnvironment, 整数型
    .参数 lpCurrentDriectory, 整数型
    .参数 lpStartupInfo, STARTUPINFO, 传址
    .参数 lpProcessInformation, PROCESS_INFORMATION, 传址

    .DLL命令 CreatePipe, 整数型, , "CreatePipe"
    .参数 phReadPipe, 整数型, 传址
    .参数 phWritePipe, 整数型, 传址
    .参数 lpPipeAttributes, SECURITY_ATTRIBUTES, 传址
    .参数 nSize, 整数型

    .DLL命令 GetStartupInfo, 整数型, , "GetStartupInfoA"
    .参数 lpStartupInfo, STARTUPINFO, 传址

    .DLL命令 ReadFile, 整数型, , "ReadFile"
    .参数 hFile, 整数型
    .参数 lpBuffer, 字节集, 传址
    .参数 nNumberOfBytesToRead, 整数型
    .参数 lpNumberOfBytesRead, 整数型, 传址
    .参数 lpOverlapped, 整数型

    .DLL命令 CloseHandle, 整数型, , "CloseHandle"
    .参数 hObject, 整数型
    .版本 2

    .DLL命令 CreateProcess, 整数型, ,

代码就只有这些,如果觉得麻烦的可以下载现成的源码
下载:点我