序言

懂得都懂 这玩应 一是自己做事情的时候要用 第二种呢就是看别人说开户然后拿来装B你正好可以揭穿他 那么我们开始教程吧

其他例子地址

java例子 -灵汐网提供

教程正文

1.先打开你的易语言 一起来创建个WINDOWS窗口程序

2.反手删除掉那窗口 Do you know ? 我们直接

3.然后新建一个程序集 叫做验证 然后创建一个子程序 叫做_启动子程序

图1

4.然后再创建个子程序 叫做校验 校验的代码填写为

.版本 2

.局部变量 IDCARD, 文本型
.局部变量 i, 整数型
.局部变量 a, 整数型, , "17"
.局部变量 当前处理文本, 文本型
.局部变量 处理完成的文本, 整数型, 静态
.局部变量 处理完成的文本2, 文本型
.局部变量 转换, 文本型, , "11"

输入框 (“”, “”, , IDCARD, , )
a = { 7, 9, 10, 5, 8, 4, 2, 1, 6, 3, 7, 9, 10, 5, 8, 4, 2 }
转换 = { “1”, “0”, “X”, “9”, “8”, “7”, “6”, “5”, “4”, “3”, “2” }
.计次循环首 (17, i)
    当前处理文本 = 取文本中间 (IDCARD, i, 1)
    处理完成的文本 = 处理完成的文本 + 到整数 (当前处理文本) × a [i]
    处理完成的文本2 = 到文本 (处理完成的文本 % 11)
.计次循环尾 ()
处理完成的文本2 = 转换 [到整数 (处理完成的文本2) + 1]
.如果 (取文本中间 (IDCARD, 18, 1) = 处理完成的文本2)
    信息框 (“错误号码” + #换行符 + “计算出的效验码:” + 处理完成的文本2 + #换行符 + “身份效验码:” + 取文本中间 (IDCARD, 18, 1), 0, , )
.否则
    信息框 (“正确号码” + #换行符 + “计算出的效验码:” + 处理完成的文本2 + #换行符 + “身份效验码:” + 取文本中间 (IDCARD, 18, 1), 0, , )
.如果结束

5.然后启动子程序下面代码填写为

.版本 2

身份验证 ()
运行 (“Explorer https://cmsboy.cn/archives/237.html”, 假, )
返回 (0)  ' 可以根据您的需要返回任意数值

返回类型 选择为整数型

图2
弄好后大概的预览就是这样的
然后我们运行它输入个正确的身份证号和错误的来试试能不能识别吧

源码下载

下载

成品下载

下载

最后修改:2021 年 01 月 30 日 04 : 47 PM
如果觉得我的文章对你有用,请随意赞赏